summaryrefslogtreecommitdiff
path: root/rpm/finesketch.spec
diff options
context:
space:
mode:
authorJavier <dev.git@javispedro.com>2015-01-13 11:29:11 +0100
committerJavier <dev.git@javispedro.com>2015-01-13 11:29:11 +0100
commit1e327a6d6d5eac09f5692d9091043e87ea688e5d (patch)
tree90173c457e7c07426d7f7267b68b69d4f9c3e2c8 /rpm/finesketch.spec
downloadfinesketch-master.tar.gz
finesketch-master.zip
initial importHEADmaster
Diffstat (limited to 'rpm/finesketch.spec')
-rw-r--r--rpm/finesketch.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/rpm/finesketch.spec b/rpm/finesketch.spec
new file mode 100644
index 0000000..d5ad334
--- /dev/null
+++ b/rpm/finesketch.spec
@@ -0,0 +1,72 @@
+#
+# Do NOT Edit the Auto-generated Part!
+# Generated by: spectacle version 0.27
+#
+
+Name: finesketch
+
+# >> macros
+# << macros
+
+%{!?qtc_qmake:%define qtc_qmake %qmake}
+%{!?qtc_qmake5:%define qtc_qmake5 %qmake5}
+%{!?qtc_make:%define qtc_make make}
+%{?qtc_builddir:%define _builddir %qtc_builddir}
+Summary: My SailfishOS Application
+Version: 0.1
+Release: 1
+Group: Qt/Qt
+License: LICENSE
+URL: http://example.org/
+Source0: %{name}-%{version}.tar.bz2
+Source100: finesketch.yaml
+Requires: sailfishsilica-qt5 >= 0.10.9
+BuildRequires: pkgconfig(sailfishapp) >= 1.0.2
+BuildRequires: pkgconfig(Qt5Core)
+BuildRequires: pkgconfig(Qt5Qml)
+BuildRequires: pkgconfig(Qt5Quick)
+BuildRequires: libgato-devel
+BuildRequires: desktop-file-utils
+
+%description
+Short description of my SailfishOS Application
+
+
+%prep
+%setup -q -n %{name}-%{version}
+
+# >> setup
+# << setup
+
+%build
+# >> build pre
+# << build pre
+
+%qtc_qmake5
+
+%qtc_make %{?_smp_mflags}
+
+# >> build post
+# << build post
+
+%install
+rm -rf %{buildroot}
+# >> install pre
+# << install pre
+%qmake5_install
+
+# >> install post
+# << install post
+
+desktop-file-install --delete-original \
+ --dir %{buildroot}%{_datadir}/applications \
+ %{buildroot}%{_datadir}/applications/*.desktop
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}
+%{_datadir}/%{name}
+%{_datadir}/applications/%{name}.desktop
+%{_datadir}/icons/hicolor/86x86/apps/%{name}.png
+# >> files
+# << files