aboutsummaryrefslogtreecommitdiff
path: root/libtopmenu-common/Makefile.am
diff options
context:
space:
mode:
authorJavier <dev.git@javispedro.com>2015-07-26 01:02:12 +0200
committerJavier <dev.git@javispedro.com>2015-07-26 01:02:12 +0200
commitbaef440d424640a6fc99edd8a12a6abcea80c5fc (patch)
tree7fb717c04564618d3c9c7b0db1c46ddde138bf5a /libtopmenu-common/Makefile.am
parentf690cd97506f45e02bb6383fde2a7c8f06820408 (diff)
downloadtopmenu-gtk-baef440d424640a6fc99edd8a12a6abcea80c5fc.tar.gz
topmenu-gtk-baef440d424640a6fc99edd8a12a6abcea80c5fc.zip
initial gtk2 "transparent" background attempt
Diffstat (limited to 'libtopmenu-common/Makefile.am')
-rw-r--r--libtopmenu-common/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/libtopmenu-common/Makefile.am b/libtopmenu-common/Makefile.am
new file mode 100644
index 0000000..7316058
--- /dev/null
+++ b/libtopmenu-common/Makefile.am
@@ -0,0 +1,17 @@
+if GTK3
+
+lib_LTLIBRARIES = libtopmenu-common-gtk3.la
+libtopmenu_common_gtk3_la_SOURCES = topmenu-background.c topmenu-background.h
+libtopmenu_common_gtk3_la_CPPFLAGS = $(GTK_CFLAGS) -DG_LOG_DOMAIN=\"topmenu-common\"
+libtopmenu_common_gtk3_la_LIBADD = $(GTK_LIBS)
+
+else
+
+lib_LTLIBRARIES = libtopmenu-common-gtk2.la
+libtopmenu_common_gtk2_la_SOURCES = topmenu-background.c topmenu-background.h
+libtopmenu_common_gtk2_la_CPPFLAGS = $(GTK_CFLAGS) -DG_LOG_DOMAIN=\"topmenu-common\"
+libtopmenu_common_gtk2_la_LIBADD = $(GTK_LIBS)
+
+endif
+
+include_HEADERS = topmenu-background.h