summaryrefslogtreecommitdiff
path: root/app/build.gradle
diff options
context:
space:
mode:
authorJavier <dev.git@javispedro.com>2018-11-01 13:01:39 +0100
committerJavier <dev.git@javispedro.com>2018-11-03 23:30:02 +0100
commit3f42c61ead715884ac6b1f85c0b6054ff437646d (patch)
tree88c9138b8a12d1f2bc60a85ad953a74b4c5c7ed0 /app/build.gradle
downloadvndroid-3f42c61ead715884ac6b1f85c0b6054ff437646d.tar.gz
vndroid-3f42c61ead715884ac6b1f85c0b6054ff437646d.zip
Initial import
Diffstat (limited to 'app/build.gradle')
-rw-r--r--app/build.gradle44
1 files changed, 44 insertions, 0 deletions
diff --git a/app/build.gradle b/app/build.gradle
new file mode 100644
index 0000000..523c8a4
--- /dev/null
+++ b/app/build.gradle
@@ -0,0 +1,44 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 28
+ defaultConfig {
+ applicationId "com.javispedro.vndroid"
+ minSdkVersion 26
+ targetSdkVersion 28
+ versionCode 1
+ versionName "1.0"
+ testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
+ ndk {
+ //abiFilters 'x86'
+ }
+ externalNativeBuild {
+ cmake {
+ targets 'native-lib', 'libssl', 'jpeg', 'vncserver'
+ }
+ }
+ }
+ buildTypes {
+ release {
+ minifyEnabled false
+ proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
+ }
+ }
+ externalNativeBuild {
+ cmake {
+ path "CMakeLists.txt"
+ }
+ }
+ productFlavors {
+ }
+}
+
+dependencies {
+ implementation fileTree(include: ['*.jar'], dir: 'libs')
+ implementation 'com.android.support:appcompat-v7:28.0.0'
+ implementation 'com.android.support.constraint:constraint-layout:1.1.3'
+ implementation 'com.android.support:support-v4:28.0.0'
+ testImplementation 'junit:junit:4.12'
+ androidTestImplementation 'com.android.support.test:runner:1.0.2'
+ androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
+}