summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog19
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules4
3 files changed, 27 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 17d9c0e..fdd0fdb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+cfmradio (0.3.2) unstable; urgency=low
+
+ * Playing with making presets a GtkTreeModel.
+
+ -- Javier S. Pedro <maemo@javispedro.com> Sat, 22 Jan 2011 04:01:30 +0100
+
+cfmradio (0.3.1) unstable; urgency=low
+
+ * Fixing bug while scrolling in the presets dialog.
+ * Reduced binary size by removing most public symbols.
+
+ -- Javier S. Pedro <maemo@javispedro.com> Fri, 21 Jan 2011 18:56:25 +0100
+
+cfmradio (0.3) unstable; urgency=low
+
+ * Testing audio routing (currently ifdef'd out).
+
+ -- Javier S. Pedro <maemo@javispedro.com> Fri, 21 Jan 2011 16:22:44 +0100
+
cfmradio (0.2) unstable; urgency=low
* Implementing presets.
diff --git a/debian/control b/debian/control
index 21bb97e..144234d 100644
--- a/debian/control
+++ b/debian/control
@@ -10,10 +10,11 @@ Package: cfmradio
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, n900-fmrx-enabler
Description: FM radio player
- Listen to FM radio from your N900
+ A FM radio player written in plain C using Hildon with a minimalist interface.
XB-Description-es_ES: Reproductor de radio FM
- Escucha radio FM desde tu N900
-XSBC-Maemo-Display-Name: Radio
+ Un reproductor de radio FM escrito en C usando Hildon con una interfaz
+ minimalista.
+XSBC-Maemo-Display-Name: C FM Radio
XB-Maemo-Icon-26:
iVBORw0KGgoAAAANSUhEUgAAAEAAAABACAYAAACqaXHeAAAAAXNSR0IArs4c6QAA
AAZiS0dEAP8A/wD/oL2nkwAAAAlwSFlzAAALEwAACxMBAJqcGAAAAAd0SU1FB9oK
diff --git a/debian/rules b/debian/rules
index ef96488..cbfdb57 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,7 @@
#export DH_VERBOSE=1
CFLAGS = -Wall -g
+LDFLAGS = -Wl,--as-needed
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
@@ -17,6 +18,9 @@ else
CFLAGS += -Os
endif
+export CFLAGS
+export LDFLAGS
+
build: build-stamp
build-stamp: