aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier <dev.git@javispedro.com>2018-01-07 18:18:44 +0100
committerJavier <dev.git@javispedro.com>2018-01-07 18:18:44 +0100
commit1dd7a1791cddd829be08edfc32c3b45c22900383 (patch)
treef17631b6a01e51f2e1a1710e4265210df35bfb89 /configure.ac
parent6d7ccc43da032c9e43094a127d584c885901acac (diff)
downloadtopmenu-gtk-1dd7a1791cddd829be08edfc32c3b45c22900383.tar.gz
topmenu-gtk-1dd7a1791cddd829be08edfc32c3b45c22900383.zip
require path to gtk3 source code instead of hardcoding private members
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c8c43e..ce07299 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,10 @@ AC_ARG_WITH([gtk-module-dir],
[AS_HELP_STRING([--with-gtk-module-dir=DIR], [GTK+ module directory [default=`pkg-config --variable=libdir gtk+-3.0`/gtk-3.0/modules]])],
[],
[with_gtk_module_dir=$with_gtk_libdir/gtk-$with_gtk.0/modules])
+AC_ARG_WITH([gtk-srcdir],
+ [AS_HELP_STRING([--with-gtk-srcdir=DIR], [GTK+ source directory (only for GTK+ 3)])],
+ [],
+ [with_gtk_srcdir=])
AC_ARG_WITH([lxpanel-plugin-dir],
[AS_HELP_STRING([--with-lxpanel-plugin-dir=DIR], [LXPanel plugin directory [default=`pkg-config --variable=pluginsdir lxpanel`]])],
[],
@@ -61,7 +65,10 @@ PKG_CHECK_MODULES([GTK], [gtk+-x11-$with_gtk.0])
PKG_CHECK_MODULES([X11], [x11])
AS_IF([test "x$with_gtk" = x3],
- [AS_IF([test "x$with_wnck" = xwnck3 -o "x$with_wnck" = xcheck],
+ [AS_IF([test "x$with_gtk_srcdir" = x],
+ [AC_MSG_FAILURE([--with-gtk-srcdir was not specified.])],
+ [GTK_CFLAGS="-I$with_gtk_srcdir $GTK_CFLAGS"])
+ AS_IF([test "x$with_wnck" = xwnck3 -o "x$with_wnck" = xcheck],
[PKG_CHECK_MODULES([WNCK3], [libwnck-3.0],
[
AC_DEFINE([HAVE_WNCK3], [1], [Define if you have libwnck-3.0])