aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Lehner <cel@celehner.com>2015-11-22 17:24:15 -0500
committerJavier <dev.git@javispedro.com>2015-12-10 19:56:42 +0100
commitd72b28afcb1e1e5d630a214eb6a9217e30d90d50 (patch)
treedbbff9f13513e2767eb0d581b7a6a87f2e72f265 /configure.ac
parentf690cd97506f45e02bb6383fde2a7c8f06820408 (diff)
downloadtopmenu-gtk-d72b28afcb1e1e5d630a214eb6a9217e30d90d50.tar.gz
topmenu-gtk-d72b28afcb1e1e5d630a214eb6a9217e30d90d50.zip
Add LXPanel plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c67f7a..a245bbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,10 @@ AC_ARG_WITH([gtk-module-dir],
[AS_HELP_STRING([--with-gtk-module-dir=DIR], [GTK+ module directory [default=`pkg-config --variable=libdir gtk+-3.0`/gtk-3.0/modules]])],
[],
[with_gtk_module_dir=$with_gtk_libdir/gtk-$with_gtk.0/modules])
+AC_ARG_WITH([lxpanel-plugin-dir],
+ [AS_HELP_STRING([--with-lxpanel-plugin-dir=DIR], [LXPanel plugin directory [default=`pkg-config --variable=pluginsdir lxpanel`]])],
+ [],
+ [with_lxpanel_plugin_dir=$with_gtk_libdir/lxpanel/plugins])
AC_ARG_WITH([wnck],
[AS_HELP_STRING([--with-wnck], [support window management using [wnck1|wnck3|matewnck] @<:@default=check@:>@])],
[],
@@ -36,10 +40,16 @@ AC_ARG_ENABLE([xfce-applet],
[],
[enable_xfce_applet=check])
+AC_ARG_ENABLE([lxpanel-plugin],
+ [AS_HELP_STRING([--enable-lxpanel-plugin], [build the LXPanel plugin @<:@default=check@:>@])],
+ [],
+ [enable_lxpanel_plugin=check])
+
AM_CONDITIONAL([GTK3], [test GTK$with_gtk = GTK3])
AC_SUBST([GTK_VERSION], [$with_gtk])
AC_DEFINE_UNQUOTED([GTK_VERSION], [$with_gtk], [Define to GTK major version used])
AC_SUBST([GTK_MODULE_DIR], [$with_gtk_module_dir])
+AC_SUBST([LXPANEL_PLUGIN_DIR], [$with_lxpanel_plugin_dir])
# Checks for programs.
AC_PROG_CC
@@ -102,10 +112,22 @@ AS_IF([test "x$with_gtk" = x3],
[if test "x$enable_xfce_applet" = xyes; then
AC_MSG_FAILURE([--enable-xfce-applet was given, but test for libxfce4panel failed])
fi]
+ )])
+
+ AS_IF([test "x$enable_lxpanel_plugin" != xno],
+ [PKG_CHECK_MODULES([LXPANELPLUGIN], [lxpanel >= 0.8.0 libfm >= 1.2.3],
+ [
+ AC_DEFINE([HAVE_LXPANEL], [1], [Define if you have lxpanel])
+ enable_lxpanel_plugin=yes
+ ],
+ [if test "x$enable_lxpanel_plugin" = xyes; then
+ AC_MSG_FAILURE([--enable-lxpanel-plugin was given, but test for lxpanel failed])
+ fi]
)])])
AM_CONDITIONAL([WANT_MATE_APPLET], [test x$enable_mate_applet = xyes])
AM_CONDITIONAL([WANT_XFCE_APPLET], [test x$enable_xfce_applet = xyes])
+AM_CONDITIONAL([WANT_LXPANEL_PLUGIN], [test x$enable_lxpanel_plugin = xyes])
# Output files
AC_CONFIG_FILES([
@@ -115,6 +137,7 @@ AC_CONFIG_FILES([
module/Makefile
mate-applet/Makefile
xfce-applet/Makefile
+ lxpanel-plugin/Makefile
icons/Makefile
test/Makefile
])