aboutsummaryrefslogtreecommitdiff
path: root/lxpanel-plugin/Makefile.am
diff options
context:
space:
mode:
authorCharles Lehner <cel@celehner.com>2015-11-22 17:24:15 -0500
committerJavier <dev.git@javispedro.com>2015-12-10 19:56:42 +0100
commitd72b28afcb1e1e5d630a214eb6a9217e30d90d50 (patch)
treedbbff9f13513e2767eb0d581b7a6a87f2e72f265 /lxpanel-plugin/Makefile.am
parentf690cd97506f45e02bb6383fde2a7c8f06820408 (diff)
downloadtopmenu-gtk-d72b28afcb1e1e5d630a214eb6a9217e30d90d50.tar.gz
topmenu-gtk-d72b28afcb1e1e5d630a214eb6a9217e30d90d50.zip
Add LXPanel plugin
Diffstat (limited to 'lxpanel-plugin/Makefile.am')
-rw-r--r--lxpanel-plugin/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lxpanel-plugin/Makefile.am b/lxpanel-plugin/Makefile.am
new file mode 100644
index 0000000..eb44246
--- /dev/null
+++ b/lxpanel-plugin/Makefile.am
@@ -0,0 +1,11 @@
+if WANT_LXPANEL_PLUGIN
+
+plugindir = $(LXPANEL_PLUGIN_DIR)
+plugin_LTLIBRARIES = libtopmenu.la
+
+libtopmenu_la_SOURCES = topmenu-lxpanel-plugin.c
+libtopmenu_la_CPPFLAGS = $(GTK_CFLAGS) $(LXPANELPLUGIN_CFLAGS) -DG_LOG_DOMAIN=\"topmenu-xfce-panel-applet\"
+libtopmenu_la_LIBADD = $(GTK_LIBS) $(LXPANELPLUGIN_LIBS) ../libtopmenu-server/libtopmenu-server-gtk$(GTK_VERSION).la
+libtopmenu_la_LDFLAGS = -avoid-version -shared -no-undefined
+
+endif