aboutsummaryrefslogtreecommitdiff
path: root/lxpanel-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lxpanel-plugin/Makefile.am')
-rw-r--r--lxpanel-plugin/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lxpanel-plugin/Makefile.am b/lxpanel-plugin/Makefile.am
new file mode 100644
index 0000000..eb44246
--- /dev/null
+++ b/lxpanel-plugin/Makefile.am
@@ -0,0 +1,11 @@
+if WANT_LXPANEL_PLUGIN
+
+plugindir = $(LXPANEL_PLUGIN_DIR)
+plugin_LTLIBRARIES = libtopmenu.la
+
+libtopmenu_la_SOURCES = topmenu-lxpanel-plugin.c
+libtopmenu_la_CPPFLAGS = $(GTK_CFLAGS) $(LXPANELPLUGIN_CFLAGS) -DG_LOG_DOMAIN=\"topmenu-xfce-panel-applet\"
+libtopmenu_la_LIBADD = $(GTK_LIBS) $(LXPANELPLUGIN_LIBS) ../libtopmenu-server/libtopmenu-server-gtk$(GTK_VERSION).la
+libtopmenu_la_LDFLAGS = -avoid-version -shared -no-undefined
+
+endif